We're updating the issue view to help you get more done. 

Upgrade to Symfony 3.4

Description

Background

Integrated 0.8 will require Symfony 3.4

Requirements

  • On Symfony 2.8 and 3.4, run the two tools mentioned on https://knpuniversity.com/screencast/symfony3-upgrade/deprecation-fixing-tools. Fix all deprecated code.

  • On Symfony 2.8 and 3.4, run unit tests and Behat tests to find deprecated warnings. Fix all deprecated code.

  • Move Symfony version to 3.4

  • Set up the new directory structure for the skeleton

  • Run unit tests and Behat tests again. Fix all errors.

Deployment actions

Integrated 0.8 ships with Symfony 3.4. Follow the upgrade guides from Symfony when upgrading your code from Symfony 2.8 to 3.4:

Other changes are:

  • The Integrated bundles are combined in one repository. Load integrated/integrated as composer package

  • The view directories within Integrated are now lowercase (following the Symfony best practices)

  • For mongodb_options in parameters.yml you might need to replace "db" with "authSource" to specify the authentication database

  • Uglyfyjs is not required any more, becuase of future Webpack migration

Technical tasks

None

Status

Assignee

Unassigned

Reporter

Marijn Otte

Product owner

Marijn Otte

OTM project ID

None

Client

Integrated Marijn

Plan date

None

Developer

Jeroen van Leeuwen

Code reviewer

Ger Jan van den Bosch

Max. hours

None

Error message

None

Follow up date

None

Switches

None

Refiner

None

Story Points

13

Time tracking

54h 30m

Epic Link

Sprint

None

Fix versions

Priority

Major